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1 Introduction and Background

1.1 The data recorded at Beamline 4A

The raw data recorded at the magnetism reflectometer stores each detected neutron as one event,
which includes information on the position on the detector, the relative time passed after the neu-
tron pulse was created at the target, the absolute time of the according pulse and some instrument
flags as the flipper ON/OFF state. After one run is finished this data is translated to the NeXus
(.nxs) file format (which is based on the HDF5 standard) as two separate files, one with event
information (flexible) and one with 3D histograms in X,Y and time of flight coordinates (fast).

While the X and Y position can be used in conjunction with the instrument motor positions to
gain information about the scattering angle the time of flight (ToF) together with the moderator
to detector distance allows to deduce the neutron wavelength. Combining these three degrees
of freedom allows to transform the coordinates into reciprocal space coordinates (for reflectivity
only the Qz coordinate is relevant).

In order to derive the correct Qz dependent intensities a normalization to the incident beam is
necessary. For this the direct beam intensity of the same wavelength band and with the same in-
strumental setup is measured prior to the actual data. This measurement is later used as reference
when calculating the reflectivity. When different incident angles are measured (as is most often
the case), each incident angle takes a different part out of the direct beam and generally won’t
have the same overall scaling factor as the previous measurement. For the extracted reflectivity
these different runs need to be combined.

1.2 What does QuickNXS data reduction do?

QuickNXS is a comprehensive tool to carry out the operations described above starting from
the NeXus files and export the data in a form usable for plotting and fitting with reflectivity
modeling software. The program includes real time plots of several projections of the raw file
data and previews of the exported data. Several automated algorithms aid the process to improve
the learning curve of non expert users and speed up the extraction process of normal datasets
while keeping the flexibility to apply special treatments for more complicated cases. For a
quick start reflectivity extraction guide see section 3.3.
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2 User Interface

2.1 Overview

In addition to the default elements of a typical graphical user interface (GUI) like menu-, tool-
and statusbar the QuickNXS program has a central area, which can be switch using the tab bar
above, and several plot and option areas on the left and right side, always visible. Most users
will work only with the "Overview" tab visible in the image above as it contains all valuable
information about the current loaded dataset and the reduction parameters. The left and right
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2 User Interface

areas can be customized in size and hold parameter entries for the reduction as well as the pro-
jection and reflectivity plots, most important for the extraction. The other tabs, shown below,
allow a parallel view of the 2D maps of all spin states in the active dataset as well as a preview of
off-specular and GISANS scattering, motor/controller logs from the current file and a large plot
area to compare different reflectivities extracted earlier.

X-Y-Maps X-ToF-Maps Off-Specular DAS Logs

Each of the plots has its own toolbar described in the plots section and shows one specific aspect
of your dataset. It is often important to look not only on one of these plots to analyze the data, so
it is good to familiarize with what you see there.

All options available in the main toolbar are duplicated somewhere in the menus, to make it
easier to find what you need. The most important actions have keystrokes assigned to them for
convenience. The keys have been chosen to be accessible only with the left hand, so you can use
them together with the mouse. Most GUI elements have a tool tip assigned, so you can always
position the mouse cursor over any element to get a more detailed description, what it is used
for.

2.2 Menu and toolbar actions

File -> Open... (CTRL+O) Shows a dialog to select a file to be loaded. The filename filter
depends on the selection of "Histogram" or "Event" mode in the Files area.

File -> Open Sum... (CTRL+SHIFT+O) Allows to open several files to sum up their inten-
sities for measurements split in to multiple runs.

File -> Next File (CTRL+D) Opens the file below the active selection in the Files area.

File -> Previous File (CTRL+SHIFT+D) Opens the file above the active selection in the
Files area.
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2 User Interface

File -> Load Extraction... (CTRL+ALT+O) Reads the header of an exported dataset (.dat)
to reconstruct the options and load the data files used for the reduction. This can be used
to improve an already exported dataset.

Reduction -> Set Normalization (CTRL+W) Use the data extracted from the current file
as a direct beam dataset. You can add as many of these datasets as you like or remove
them by activating this action again. The appropriate direct beam run is selected using the
number of time of flight channels in the file and the central wavelength, if this is ambiguous
a dialog is shown to select one dataset, unless the AutoNorm feature is active.

Reduction -> Clear Normalization (CTRL+SHIFT+W) Empty the list of direct beam
datasets.

Reduction -> Set Scaling (CTRL+S) For the first dataset this tries to find the edge of
total reflection and fits a constant to all points before it to normalizes it to one. For sub-
sequent datasets it fits a polynomial to the overlapping region of the active dataset and the
closest one found in the reduction table to stitch them together. It is helpful to first define
a suitable range of cut points to improve the results.

Reduction -> Cut Points (L/R) (CTRL+SHIFT+C) Tries to select good cut points for
the given wavelength band based on the corresponding direct beam measurement.

Reduction -> Keep Item in List (CTRL+Q) Use the reflectivity from the current dataset
and add it to the reduction list. Only works for dataset with direct beam run. The options
in the reduction list can still be changed later.

Reduction -> Remove Line Remove the selected line from the reduction list.

Reduction -> Clear List (CTRL+SHIFT+Q) Clear the full reduction list to start a new
reflectivity set.

Reduction -> Reduce... Use the items and options in the reduction table to export a dataset.
Shows a dialog to select how the export should be done.

Reduction -> Quick-Reduce... As Reduce but doesn’t show the export dialog using the last
set of options.

Automatics -> Automatic Peak Finder If checked, the program runs a peak finder and
peak fitting algorithm on the X-projection of the data each time a new dataset is loaded
and sets the X-center parameter accordingly. This works very reliable in general and is
activated by default.

Automatics -> Automatic Y Limits If checked, the program detects the region, where
the intensity in the Y-projection drops below a certain threshold and sets the Y-center and
Y-width parameters accordingly. After adding the first dataset to the reduction table the
option is switched off automatically to prevent issues at higher incident angle, where the
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2 User Interface

intensity is comparable with the background. Clearing the reduction list will reactivate the
option.

Automatics -> AutoNorm If more then one normalization datasets are defined that can be
used for the current dataset the program will decide which to use based on slit settings.

Automatics -> Auto Reflectivity When extracting several reflectivities with similar ex-
perimental setup the extraction parameters will likely be similar, as well. Activate this
action at the total reflection run and it will use the current settings to subsequently scale
and add all following datasets as long as the incident angle increases. Afterwards the Strip
Overlap action is invoked. For good quality data this is a convenient way to reduce the
full reflectivity very quickly.

Automatics -> Strip Overlap This option can be invoked directly before reducing the data
to remove overlapping points between subsequent runs. The points are removed from the
lower Qz run, as these normally will have much lower statistics.

Tools -> Open Compare Window... Open a dialog which allows the direct comparison of
different reflectivity measurements, can be used several times and is equivalent to the Com-
pare tab of the main window.

Tools -> Open Reduction Preview... Open a dialog which shows a preview of the extracted
reflectivity with all spin states. Keeping this window open will slow down some actions.

Tools -> Filter Points... Allows you to post-process exported files by filtering specific data
points.

Tools -> Search Database... This options is not always possible. It opens a dialog that
allows the search for datasets based on specific parameters of the measurement.

Advanced -> Advanced Background ... (CTRL+B) Open a dialog with additional options
for the background subtraction.

Advanced -> Adjust Direct Beam For datasets where the direct pixel and or DANGLE0
values are not correctly defined, this action can take the current X-position of a direct beam
measurement to set overwrite parameters accordingly.

Advanced -> Clear Overwrite This clears the overwrite parameters defined with "Adjust
Direct Beam".

Advanced -> Polarization... Open a tool to plot polarization parameters of dedicated mea-
surements. Not intended for users.

Advanced -> Raw Data Comparison... Show a dialog to compare the raw data of the cur-
rent run (not divided by direct beam) with the direct beam measurement and background.
Can be helpful to identify problems with the direct beam normalization or the extraction
window.
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2 User Interface

Advanced -> Browse NXS file... (CTRL+N) Show a dialog that accesses the raw NXS file
with it’s folder structure. This is only intended for beamline staff.

Advanced -> IPython Console... Adds a new tab to the main window with an IPython in-
teractive console, that can be used for advanced data treatment and scripting.

Advanced -> Debug Menu Useful things for program debugging.

Help Menu Online access to this manual and an about dialog.

2.3 The Overview Tab

This central tab shows information on the current dataset and the data reduction. A label at the
top indicates the current file number, experiment ID, measurement type and the currently selected
spin state. The two map plots below the label show the projected intensities on the horizontal
and vertical detector axes (left) and on the time of flight and horizontal detector axes (right), in
the same way as it is show during data acquisition. In the center some important parameters,
extracted from the datafile header, are displayed. The SANGLE-calc and Counts ROI parameters
also depends on the selected X- and Y- region and are thus not directly read from the file. The
mouse can be used to define the X- and Y-region in this plots similar as in the projection areas
described below.

At the bottom you can find the reduction table and an additional tab with a list of defined direct
beam datasets. These tables show the parameters used for the respective intensity extractions.
The parameters in the Data tab can be edited afterwards and will be applied directly to the re-
flectivity curve shown in the Reflectivity area. Directly above the table is a label showing the
numbers of all defined direct beam runs and radio buttons to select the current datasets spin state
shown in the Overview, projections and reflectivity plots.

2.4 Plots and Options

The areas on the left and right of the window contain e.g. the projection plots and extraction
parameters and are visible on any tab of the main interface. The left side contains option fields
for the extraction parameters and file readout while the right side is dedicated for important plots.
Here is a list of the available areas from top to bottom, first on the left and than on the right hand
side.

Files A list of all datafiles in the current directory together with an entry to search for a file
by number and select to extract either histogram or event mode data. In the event mode
setting additional options will be displayed.
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2 User Interface

Reflectivity Extraction (Basic) The parameters used to extract the active reflectivity. When
adding a dataset to the reduction list, these parameters are stored in the Data table.

Reflectivity Extraction (Advanced) Settings to change the extraction method or overwrite
parameters otherwise read from the datafile. Options for the stitching algorithm can be
found here as well.

Peak Finder Algorithm Settings for the peak finder algorithm not important for normal user
operation.

Plot Options Global settings for the shown plots, does not effect the data reduction in any
way. Here you can also chose to show the 2D datasets in wavelength and angle coordinates
instead of time of flight and pixel.

X-Projection A plot with the data of the loaded file projected on the detector X-axis. Black
lines indicate the background region defined at the moment. The X-position is marked
with a black line and the X-width with two red lines. The mouse can be used to change the
background region and X-center using the left mouse button and set the X-width using the
right mouse button.

Y-Projection An equivalent projection on the detector Y-axis, showing the selected Y-region
with green lines. The mouse can be used to change the Y-region using left clicks.

Reflectivity Shows all datasets already added to the reduction list (colored lines) and the cur-
rently selected one (black line labeled ’Active’). For datasets without fitting direct beam
runs it shows intensity and background vs. wavelength. Datasets in the reduction list can
be scaled with the mouse wheel when at the right x-coordinates (faster scaling when CTRL
is pressed while scrolling). Note that a dataset can be shown twice (as "Active" and with
it’s run number) when it is already in the reduction list and selected.

2.5 Convenient Parameter Alteration with the Mouse
Wheel

You can use the mouse wheel when your cursor is on top of a value
entry to increase or decrease the according parameter. This can be
very convenient to see the result of e.g. changing the scaling factor for
the current reflectivity. Holding down the CTRL key while scrolling
increases the speed of the parameter changes. The same method can
also be used to scale datasets in the reduction table, simply by moving
the mouse at the curve in the reflectivity plot and scrolling with the
mouse wheel.

9



2 User Interface

2.6 Plots

Each of the plots described above are created with the same framework and have a toolbar below
them:

The first 5 items allow the navigation on the plot, like zooming in and out or moving the current
view position. The fourth icon from the left opens a dialog, which can be used to change the
amount of free space around the plot to fit the current window scaling. The following two icons
can be used to save or print the plot. The last button allows to toggle between logarithmic and
linear plotting (this is not persistent after changing the dataset).

Keep in mind that the X- and Y-projections as well as the overview maps can be used to
select the extraction parameters. This will only work when no scaling tool is selected from the
plot toolbar.

2.7 Data reduction table

Each entry created in the reduction table shows all important parameters needed for reflectivity
extraction. In addition to the parameters found in the Reflectivity Extraction area there is a value
for the direct pixel (DPix) and relative detector arm position DANGLE-DANGLE0 (TTH) as
well as the dataset and normalization file number. Changing any of the reduction parameters
(except for the two file number columns) immediately recalculates the extracted reflectivity. All
lines present in the reduction table are plotted together with the current dataset in the Reflectivity
Extraction area.

10



3 Data Reduction

3.1 Open and view a dataset

The first step to start with is to enter the number of a direct beam dataset in the "Open Number:"
entry of the Files area and press enter. The program will now locate the file and open it. The
Files area list will be populated with all files in your current proposal data folder and the plot
windows should look similar to this:

Overview X-Y Overview ToF-X

X-Projection Y-Projection Reflectivity

3.2 Go full-automatic: Reduction for dummies

For good quality data (enough intensity and narrow reflection) the program supports a fully
automatized mode, where all reduction parameters are automatically calculated. This mode will
be applied automatically when more than one dataset is selected at the File Open Dialog. The
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3 Data Reduction

direct beam measurements have to have lower scan numbers than the actual measurements or
need to be set in advance for this method to work.

The automatic algorithm performs the same steps as described in section 3.3, while trying to
guess the best parameters. The datasets are read one-by-one and, depending on the reflection
angle, they are either set as direct beam or reflectivity data in the reduction list. Here is an
example how the interface might look after the algorithm has finished:

You can now scale individual datasets as described in 3.3.5, if the stitching was not performed
optimally. When satisfied with the result, you can save the data as described in the export section
3.3.6.
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3 Data Reduction

3.3 Quick start: Step-by-step standard reduction

For most datasets the reduction is done very similar to the fully automatized method but with
more control by the user. Every dataset is examined by the operator to select the best extraction
parameters. This description should work in almost all circumstances.

3.3.1 Step 1: Set direct beam runs

Reflectivity before Reflectivity after
Open your direct beam file as described
in section 3.1. Make sure the SANGLE-
calc value shown in the overview tab is
close to zero and that the X- and Y-
projections show the correct regions indi-
cated with vertical lines. Activate the Set
Normalization action . This will add
the current dataset to the "Direct Beam"
list and the "Direct Beam Runs:" label
will show the number of the dataset and the reflectivity will show the normalized intensities,
which should all be one. You can use the Cut Points (L/R) action here to already set rea-
sonable parameters for the Cut Pts entries. Repeat this step for each direct beam measurement
needed for your datasets.

3.3.2 Step 2: Define a suitable background- and y-region

X-projection with background region (green)

Y-projection of small sample X-Y map

Although it is in principle possible
to define the extraction and back-
ground region for each dataset sep-
arately, it is recommended to use the
same parameters for all files. From
this perspective it is often a good
idea to start with the dataset with the
highest incident angle for the back-
ground, as the signal to background
ration is the lowest there. To pro-
duce the best results you should se-
lect a large region (statistics), keep-
ing enough distance from the re-
flected beam (especially when off-
specular Bragg-sheets are present)
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3 Data Reduction

and to not include regions where the background drops (shadowed by the left detector slit for
example). The Y-region, shown in the Y-projection of the first (low Q) dataset, is often detected
very well automatically. Just check that it fits to the reflected intensity area. For very small sam-
ples it can sometimes make sense to manually restrain the area to the sample reflection using the
right mouse button on the X-Y map.

3.3.3 Step 3: Normalize to total reflection and add the first dataset

Go to your dataset starting at the lowest Qz value
and remove points which are not reasonable from
the low Qz region with the Cut Pts parameters:

(can be done automatically
with the Cut Points (L/R) action if not already per-
formed after direct beam selection). Than activate the
Set Scaling action to normalize the total reflection
to one. This should now look like the image on the
right. Next add the dataset to the refinement list using
the Keep Item in List action , copying the current
parameters to the list. This will automatically switch
off the Automatic Y Limits , so all datasets will be
reduced with the same Y-range. This is important for the high Qz region as the background often
inhibits a good automatic detection of the Y-region.

3.3.4 Step 4: Add additional datasets and stitch them together

Now you can continue adding each subsequent dataset
one after another. If nothing goes wrong, the only thing
that needs to be changed from dataset to dataset is the
Scaling parameter. If the scaling of subsequent datasets
does not fit, activate the Set Scaling action again.
This fits a polynomial to the logarithmic data of both
adjacent datasets including a scaling factor for the sec-
ond, which is than used for the scaling after the fit. The
error weighted χ2 used for this refinement is:

χ
2
stitch = ∑

DS1

(log(Ii)−p(Qi))
2

(δ Ii/Ii)2 + ∑
DS2

(log(I j·scale)−p(Q j))
2

(δ I j/I j)2

with p(Q) = a ·Q2 +b ·Q+ c for polynom order 3
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3 Data Reduction

The resulting fit function is shown in the reflectivity plot together with the scaled data as can
be seen in the figure on the right. For some datasets with very sharp features like multilayer
Bragg-peaks this method will probably not work, in those cases you need to change the Scale
10ˆ parameter manually until the datasets fit together nicely. For polarized measurements it
can sometimes be helpful to switch back and forth between different polarization states as the
variation in contrast can lead to smooth transitions, where the other state has a sharp feature.
Now add the dataset to the reduction list with Keep Item in List action again and repeat the
procedure for all datasets belonging to this measurement.

3.3.5 Step 5: Refine the reflectivity scaling and cutting

When all datasets of one measurement have been added, as can
be seen in the image on the right, you can try to improve the
scaling of the different parts, if needed, and change the cutting
parameters. To change the scaling of one dataset you can either
change the value of the I0 column entry in the reduction list
or put the mouse cursor on top of the curve you want to scale
and move the mouse wheel. To remove unwanted points you
need to change the values of the NL and NR column entries as
they define the number of points cut from the low- and high-Q
side respectively. If the number of time of flight channels in the
dataset is larger than the wavelength window it is possible that large values are needed (<=60) to
see changes in the dataset. (Removing of overlapping points with low statistics can be done with
Strip Overlap .)

3.3.6 Step 6: Export your data

Now you are ready to export you reflectivity! Activate the
Reduce... action from the menu, toolbar or the button be-
low the reduction list. The reduce dialog has several options
for the export of the dataset. You can select which reductions
should be stored, choose the spin states to export and define
which data formats should be created. As a default, the spec-
ular reflectivity of all available channels will be exported to
separate ASCII files and a dialog with a plot of the result-
ing data will be shown afterwards. Additional output options
are a combined ASCII file containing all states, a matlab or
numpy datafile for later processing, a Gnuplot script and im-
age file to plot the ASCII data and a GenX reflectivity mod-
eling template already containing the measured data. If you
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3 Data Reduction

want to send the resulting data to your email address you can use the Email Results tab to enter
your address and select which and if the data should be send after the export.

3.4 Examples

This section will give three example datasets, which you can use to try the reduction yourself
and compare the result with the images in this manual.

3.5 Common complications to be aware of

Bend/Twisted samples Samples which do not have a flat surface can produce "fan"-like or
split reflections. In these cases the peak fitting can result in different extraction areas for
different incident angles. Use a small X window and/or the "Fan" Reflection option (see
section 4.5) from the Reflectivity Extraction (Advanced) tab and define the reflection
position manually.

Runs don’t fit together This often is caused by one of two reasons: One possibility is that
there are very sharp features in the reflectivity which are measured differently for the dif-
ferent angles, as the resolution changes with the angle. In this case the only possibility
is to try to merge the datasets manually as good as possible. If the measurement is po-
larized, take a look at the other spin state, sometimes the feature won’t be as pronounced
and make it easer to find the scaling factor. The other possibility is that the direct beam
position, which should be measured before the experiment and written to the datafile, is
not correct. This can be checked with the according direct beam run. If the SANGLE-calc
value for the direct beam run is not close to zero you can use the Adjust Direct Beam
action to overwrite the values read from the datafile. Afterwards it should be possible
to extract the reflectivity normally. Don’t forget to reset this overwrite afterwards using
Clear Overwrite (see section 4.3).
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4 Advanced Usage

4.1 Event mode data

When the event mode is selected for file import, additional options for the desired binning are
shown. You can define the number of Bins, the bin steps (constant ∆ToF, ∆Q or ∆λ/λ steps)
and split datasets in time. In all other aspects event mode data is not treated differently from
histogram data. To be able to use a direct beam measurement, it needs to be extracted with the
same binning as the actual measurement.

4.2 Re-reduction of already exported data

You can read all datasets and options from an already exported reflectivity using the File->Load
Extraction... menu and select an ASCII file. Afterwards the options in the reduction table can
be changed as desired.

4.3 Overwrite direct beam parameters

If the the direct beam position was not saved correctly during instrument alignment all calculated
Qz-values for the reflectivity will be wrong. To correct this there are two parameters to overwrite
it in the Reflectivity Extraction (Advanced) area, Direct Pixel and Dangle0. These parameters
are ignored if they have the values -1 and None. To overwrite the correct values you can open a
direct beam dataset and activate the Adjust Direct Beam action to save the current DANGLE
as Dangle0 and the fitted X-position as Direct Pixel.
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4 Advanced Usage

4.4 Advanced background subtraction

There are a few cases where you could need additional control
over the subtracted background, for this case you can use the Ad-
vance Background... action to open a dialog with more options.
An example is shown on the right. The upper plot shows the X vs.
λ plot of the current dataset, indicating the areas taken to calculate
the background data. The lower plot shows the extracted data and
background as wavelength vs. intensity plot. You can use Poly-
gons to define the extraction area for the background precisely,
these polygons are than shown in the X vs. λ plot as gray ar-
eas. The normal extraction region defined by the main window
parameters is shown in red. For each λ channel the average value
of all pixels in the gray areas is taken as background. If, for a
given value of λ, no points are defined with a polygon the red
area is taken. As an additional option it is possible to presume a
background that is directly dependent on the incident intensity to
reduce the error bars.

4.5 "Fan"-Reflectivity

Some samples have a weavy or bent surface and reflect the neutron beam into different angles.
Treating these as one reflection will destroy the Qz resolution of you measurement or needs to
be restricted to a small X-region, which reduces the statistics. For these cases the Reflectivity
Extraction (Advanced) area has a "Fan"-Reflectivity option, which treats each pixel on the
detector separately to calculate I(Qz) and combines these reflectivities afterwards to get better
statistics. In this case you can widen the red area on the X-projection plot to take your full
reflectivity into account. The underlying algorithm reduces the total width of a selected dataset
in Qz so it can be possible that for lower angles you do not get overlapping areas to stitch the data
together. In this case you should select a smaller area for the lower angle measurements and/or
extract two regions in X for one dataset.

4.6 Off-specular and GISANS scattering

Off-specular scattering can easily be extracted when the specular reflectivity is already defined
in the reduction table. You can take a look at the OffSpec Preview tab to preview it in advance
(does not show the active dataset, only the reduction table entries). The reduction dialog has a
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4 Advanced Usage

separate option to export the off-specular data, where Raw refers to the data as extractec, Cor-
rected applies an algorithm to reduce detector artifacts from high intensity areas and Smoothed
will interpolate the data to a regular grid with Qz-dependent Gaussian smoothing (parameters are
defined in a separate dialog when exporting).

The scaling factors to combine datasets for off-specular extraction will only be correct if the full
reflectivity is within the X-width and if you keep the X-width constant! These conditions need
not to be fulfilled when only specular data is extracted.

For GISANS measurements another dialog appears when exporting, where you can define the
wavelength bands, which will be combined in one image.
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